Wrong Permalinks

WP-Filebase Pro Forums General Support Wrong Permalinks

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #5135

    I have purchased the pro version and every file I add gets the permalink like “?post_type=wpfb_filepage&p=23” which does not work unless you are logged in as an admin, as a normal user this will return a 404, but this is the link it is placing on the pages and in the lists. Permalinks are enabled, but I also tried disabling them and nothing has changed. It was working wonderful until I tried to add a second package, then everything got ruined. The /files/filename links work, but that is not what WPFB is saving, anymore. Please help. Its urgent.


    My WordPress permalink settings are Post name. What is your upload path also on the WP-Filebase Pro Settings under “Common”?


    I am having the same problem. Did you ever find a solution?


    Did you try this: In Settings check the “File Page URL slug” then run the Fix File Pages tool from WP-Filebase Main screen.

    Sean Byrnes

    I mentioned this in a topic I just made, I have the exact same issue.

    The thing is, it’s only like that for a few hours after upload, then the permalink fixes itself and normal users can visit the page and comment.

    I have the File Page URL slug set and running “Fix File Pages” it reports back:
    0 missing File Pages created. Fixed 0 File Pages with wrong post type. Removed 0 obsolete File Pages.

    It’s always been this way, no idea why.


    Thi issue is known. I will release a fix within the next days.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.